В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Svetiksmail5454
Svetiksmail5454
18.12.2020 13:14 •  Информатика

Нужно написать программу, чтобы выводила один из этих рисунков
На паскале

Показать ответ
Ответ:
эдики
эдики
11.07.2021 05:30

Метод find принимает три параметра:

substring (символ/подстрока) — подстрока, которую нужно найти в данной строке.

start (необязательный) — первый индекс, с которого нужно начинать поиск. По умолчанию значение равно 0.

end (необязательный) — индекс, на котором нужно закончить поиск. По умолчанию равно длине строки.

после чего принимается данная функция

>>> string = "Добро !"

>>> start = string.find("п")

>>> end = string.find("ь") + 1

>>> print("Индекс первой буквы 'о' в подстроке:", string.find("о", start, end))

Индекс первой буквы 'о' в подстроке: -1

0,0(0 оценок)
Ответ:
hshgahahah
hshgahahah
12.08.2022 19:48

 var a: array[1..5] of integer;

     s: char;

     min, i, j, k: integer;

begin

 writeln('Введите массив:');

 for i:=1 to 5 do

 begin

   write('a[',i,'] = ');

   readln(a[i]);

 end;

 

 for i:=1 to 5 do

   write(a[i], ' ');

 writeln;

 

 write('Введите символ (x, y, z): ');

 readln(s);

 

 if (s = 'x') or (s = 'X') then

 begin

   min := a[1];

   k := 1;

   for i:= 2 to 5 do

     if min > a[i] then  

     begin

       min:= a[i];

       k:= i;

     end;

   writeln('Min = ', min, ', Index = ', k);

 end;

 

 if (s = 'y') or (s = 'Y') then

 begin

   for i:= 1 to 5 do

     for j:= 1 to 4 do

       if a[j] > a[j + 1] then

       begin

         k:= a[j];

         a[j]:= a[j + 1];

         a[j + 1]:= k;

      end;

       

   for i:=1 to 5 do

     write(a[i], ' ');

   writeln;                          

 end;

 

 if (s = 'z') or (s = 'Z') then

 begin

   for i:=1 to 5 do

     k:= k + a[i];

     

   writeln('Сумма = ', k);

 end;

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота