Нужно написать на паскале. напишите программу которая задевает массив из n элементов случайными целыми числами в диапазоне [а, в] и определяет количество чисел в массиве у которых в 6-ричной системе счисления встречается цифра 3.
begin // а) writeln('Результаты сдачи экзамена:'); var a:=ArrRandom(15,2,5); a.Println; // генерируем и выводим массив оценок var k:=a.Where(x->x=2).Count; // подсчитываем количество двоек writeln('Не сдали экзамен: ',k,' чел. Это ',100*k/15:4:1,'%'); // выводим на эран результаты // б) writeln('Данные по продаже компьютеров:'); var b:=ArrRandom(7,5,20); b.Println; // генерируем и выводим результаты продаж writeln('По возрастанию:'); b.Sorted.Println; // сортируем по возрастанию и выводим end.
Пример: Результаты сдачи экзамена: 3 3 3 2 4 3 4 4 3 3 5 2 2 5 5 Не сдали экзамен: 3 чел. Это 20.0% Данные по продаже компьютеров: 16 20 16 14 5 18 16 По возрастанию: 5 14 16 16 16 18 20
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018 // Внимание! Если программа не работает, обновите версию!
№1
begin var n:=15; var a:=ArrRandom(n,2,5); a.Println; var k2:=a.Where(t->t=2).Count; Writeln('Не сдали экзамен ',k2,' чел, что составляет ',k2/n*100:0:1,'%') end.
Пример 4 3 3 4 5 4 3 4 3 5 4 5 2 5 2 Не сдали экзамен 2 чел, что составляет 13.3%
№2
begin ArrRandom(7,15,40).Println.OrderBy(t->t).Println end.
Пример 34 21 24 29 28 22 25 21 22 24 25 28 29 34
P.S. А объяснять тут нечего - все видно из текста программы.
begin
// а)
writeln('Результаты сдачи экзамена:');
var a:=ArrRandom(15,2,5); a.Println; // генерируем и выводим массив оценок
var k:=a.Where(x->x=2).Count; // подсчитываем количество двоек
writeln('Не сдали экзамен: ',k,' чел. Это ',100*k/15:4:1,'%'); // выводим на эран результаты
// б)
writeln('Данные по продаже компьютеров:');
var b:=ArrRandom(7,5,20); b.Println; // генерируем и выводим результаты продаж
writeln('По возрастанию:');
b.Sorted.Println; // сортируем по возрастанию и выводим
end.
Пример:
Результаты сдачи экзамена:
3 3 3 2 4 3 4 4 3 3 5 2 2 5 5
Не сдали экзамен: 3 чел. Это 20.0%
Данные по продаже компьютеров:
16 20 16 14 5 18 16
По возрастанию:
5 14 16 16 16 18 20
// Внимание! Если программа не работает, обновите версию!
№1
begin
var n:=15;
var a:=ArrRandom(n,2,5); a.Println;
var k2:=a.Where(t->t=2).Count;
Writeln('Не сдали экзамен ',k2,' чел, что составляет ',k2/n*100:0:1,'%')
end.
Пример
4 3 3 4 5 4 3 4 3 5 4 5 2 5 2
Не сдали экзамен 2 чел, что составляет 13.3%
№2
begin
ArrRandom(7,15,40).Println.OrderBy(t->t).Println
end.
Пример
34 21 24 29 28 22 25
21 22 24 25 28 29 34
P.S. А объяснять тут нечего - все видно из текста программы.