Нужно:
1 написать программу которая посчитает сумму положительных (отдельно) и отрицательных (отдельно) чисел (n брать от 30 до -13 с шагом 1)
2 Написать программу, которая посчитает разность положительных чисел (отдельно) и произведение отрицательных чисел (n берем от 37 до -6 с шагом -1)
uses GraphABC;
begin
var s:=ReadlnString('Укажите время MM:CC');
var m:=s.Left(2).ToInteger;
var c:=s.Right(2).ToInteger;
var i:=m;
var j:=c;
Font.Size:=60;
Font.Color:=clBlue;
repeat
while i<60 do begin
while j<60 do begin
if i<10 then s:='0'+i+':' else s:=i+':';
if j<10 then s+='0'+j else s+=j;
FillRect(50,100,350,400);
DrawTextCentered(50,100,350,400,s);
Inc(j);
Sleep(1000)
end;
j:=0;
Writeln;
Inc(i)
end;
i:=0
until False
end.
var
a,b,c:integer;
begin
writeln('Введите три числа: ');
readln(a,b,c);
if (a>b)and(a>c) then writeln('Первое число наибольшее')
else if (a<b)and(a<c) then writeln('Первое число наименьшее')
else writeln('Первое число со средним значением');
if (b>a)and(b>c) then writeln('Второе число наибольшее')
else if (b<a)and(b<c) then writeln('Второе число наименьшее')
else writeln('Второе число со средним значением');
if (c>a)and(c>b) then writeln('Третье число наибольшее')
else if (c<a)and(c<b) then writeln('Третье число наименьшее')
else writeln('Третье число со средним значением');
end.
Проверил на Паскале