В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
00012333334
00012333334
01.10.2022 11:58 •  Информатика

нужна ваша решение на языке паскаль

На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Показать ответ
Ответ:
Ga1axI
Ga1axI
14.10.2020 05:52

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота