В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
skrylnikvozvyb6
skrylnikvozvyb6
12.03.2022 07:51 •  Информатика

Нужна ваша по программированию. ответьте на 1 вопрос Составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15].

#include
#include
void main()
{
setlocale(LC_ALL, "Rus");
int n = 0;
float sr_arifm;
for (int i = -4; i <= 15; i++)
n += i;
sr_arifm = n / float(15 - (-4) + 1);
printf("Среднее арифметическое на отрезке [-4;15]=%f", sr_arifm);
}

ВОПРОС: С какой целью использовано (float)(15)

Показать ответ
Ответ:
ziminasofa2703
ziminasofa2703
24.01.2021 21:43

Без float программа выдает ответ 5,0, а с float ответ 5,5.

Float это вещественного тип.

Их значения имеют дробную часть, отделяемую точкой, например: -5.6, 31.28

Объяснение:

#include <stdio.h>

#include <iostream>

using namespace std;

int  main()

{

setlocale(LC_ALL, "Rus");

int n = 0;

float sr_arifm;

for (int i = -4; i <= 15; i++)

n += i;

sr_arifm = n / float(15 - (-4) + 1);

printf(" Сред арифм [-4;15]=%f", sr_arifm);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота