В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mariuaivanova1
mariuaivanova1
03.09.2021 21:07 •  Информатика

Нужна в написании программы на python 3

в галактике «milky way» на планете «snowflake» есть n городов, некоторые из которых соединены дорогами. император галактики «milky way» решил провести инвентаризацию дорог на планете «snowflake». но, как оказалось, он не силен в , поэтому он просит вас сосчитать количество дорог. требуется написать программу, императору сосчитать количество дорог на планете «snowflake».
выходные данные
в результате необходимо вывести число, определяющее количество дорог на планете «snowflake».

Показать ответ
Ответ:
Drzk
Drzk
14.12.2021 16:46
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=new List<real>;
  a.AddRange(ReadSeqReal('Введите список А:',10));
  var b:=new List<real>;
  b.AddRange(ReadSeqReal('Введите список B:',10));
  var x:=new List<real>;
  x.AddRange(a.Zip(b,(p,q)->q/p));
  Write('A: '); a.Println;
  Write('B: '); b.Println;
  Write('X: '); x.Where(p->Trunc(p) mod 5=0).Println;
end.

Пример
Введите список А: 1 5 -2 3.5 12 16.3 -7 1.3 0.15 10
Введите список B: 10.4 37 -14 6.3 1 -8 -12.94 6.9 18 52
A: 1 5 -2 3.5 12 16.3 -7 1.3 0.15 10
B: 10.4 37 -14 6.3 1 -8 -12.94 6.9 18 52
X: 10.4 0.0833333333333333 -0.49079754601227 5.30769230769231 120 5.2
0,0(0 оценок)
Ответ:
kseriii
kseriii
11.04.2022 21:27
1. Современный вариант (коротко, быстро и наглядно, кто знает). Так уже начали учить в некоторых школах.

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ArrRandom(ReadInteger('n='),1,300).Println.
      Where(k->(k>=100) and ((k mod 100) div 10=0));
  if s.Count>0 then Writeln(s.Max) else Writeln('Нет элементов')
end.

Пример
n= 15
76 283 171 140 113 65 185 35 202 42 93 51 205 76 138
205

2. А так по-прежнему учат в большинстве школ. Стиль "80-х годов века". Долго, длинно, можно наделать ошибок, но по-другому эти учителя сами не могут.

const
  nn=100;
var
  i,n,max:integer;
  a:array[1..nn] of integer;
begin
  Write('n=');
  Read(n);
  Randomize;
  max:=0;
  for i:=1 to n do begin
    a[i]:=Random(300)+1;
    Write(a[i],' ');
    if (a[i]>=100) and ((a[i] mod 100) div 10=0) then
      if a[i]>max then max:=a[i]
    end;
  Writeln;
  if max>0 then Writeln(max)
  else Writeln('Нет элементов')
end.

Пример
n=15
219 68 131 115 104 169 80 288 143 108 124 214 50 101 1
108
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота