В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lennyface228
lennyface228
17.11.2022 12:13 •  Информатика

Нужна с паскалем! напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. входные данные входная строка содержит три целых числа, разделённых пробелами. выходные данные программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

Показать ответ
Ответ:
leraci2001
leraci2001
06.10.2020 03:27
Var
   a,b,c,k:integer;
Begin
k:=1;
Read(a,b,c);
if a=b then k:=k+1;
if b=c then k:=k+1;
if c=a then k:=k+1;
if k=1 then k:=0
else
   if k=4 then k:=3;
Write(k)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота