В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
andrey2085
andrey2085
04.07.2020 06:36 •  Информатика

Нужна с массивом. известно количество учащихся в каждом из к классов школ. составить программу, которая определяет, сколько всего учащихся обучается в тех классах школы, в которых меньше, чем 30 человек. заранее

Показать ответ
Ответ:
tarasbulba204
tarasbulba204
10.08.2020 22:16
Var sum{кол-во учащихся, ответ},k,i:integer;
      a:array[1..1000] of integer;
begin
readln(k);  
sum:=0;
For i:=1 to k do
  readln(a[i]);
For i:=1 to k do
   If a[i]<30 then    {Если кол-во учащихся в классе <30 то прибавляем}
      sum:=sum+30;
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота