В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastunya22
nastunya22
13.09.2022 06:00 •  Информатика

Нужна программа на паскале, которая выполняет деление и возведение в степень разных переменных и записывает в конец файла.

Показать ответ
Ответ:
Дарья20099
Дарья20099
12.12.2021 09:09

использовать Чертежник

алг

нач

сместиться в точку (2,4)

б

а

о

б

а

б

кон

алг б

нач

опустить перо

сместиться на вектор (-2,0)

сместиться на вектор (0,-4)

сместиться на вектор (2,0)

сместиться на вектор (0,2)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (3,-2)

кон

алг а

нач

опустить перо

сместиться на вектор (0,2)

сместиться на вектор (2,2)

сместиться на вектор (0,-4)

сместиться на вектор (0,1)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (5,3)

кон

алг о

нач

опустить перо

сместиться на вектор (-2,0)

сместиться на вектор (0,-4)

сместиться на вектор (2,0)

сместиться на вектор (0,4)

поднять перо

сместиться на вектор (3,0)

кон

Объяснение:

картинка


Для исполнителя Чертёжник в среде программирования КуМир составьте программу рисования слова БАОБАБ.
0,0(0 оценок)
Ответ:
kirovaalex16
kirovaalex16
08.01.2021 09:37

program z1;

var a:array [1..21] of integer;

i,m: integer;

begin;

write('0.');

for i:=1 to 21 do

begin

a[i]:=random(66)-13;

write(a[i]:5)

end;

writeln;

write('1.');

for i:=1 to 21 do

begin

if i mod 2 = 0 then a[i]:=-3*a[i];

write(a[i]:5)

end;

writeln;

write('2.');

for i:=1 to 21 do

begin

if a[i] < 10 then a[i]:=-a[i];

write(a[i]:5)

end;

writeln;

write('3.');

for i:=1 to 21 do

begin

if abs(a[i]) > 40 then a[i]:=a[i]-15;

write(a[i]:5)

end;

writeln;

m:=1;

for i:=1 to 21 do if a[m] < a[i] then m:=i;

a[m]:=m*m;

write('4.');

for i:=1 to 21 do write(a[i]:5)

end.

Объяснение:

После каждого преобразования выводится получившийся массив

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота