В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Даша07кбр
Даша07кбр
26.12.2021 21:39 •  Информатика

Номер 1 Найдите соответствия:

1 program p2 1Процедура вывода на экран

2 var a,b,c:integer 2Процедура ввода с клавиатуры

3 begin 3 Заголовок программ

4 realdnl (a,b) 4 Конец раздела операторов

5 c:=a+b 5 Раздел операторов

6 writeln ('c=',c); 6 Оператор присваивания

7 end 7 Начало раздела операторов

Номер 2

Что будет выведено на экран в результате выполнения первого задания ,если с клавиатуры вывести 7 3 ?

Что означает найденная величина?

Номер 3

Из задания номер один выпишите лексические единицы :

1Ключевые слова

2Индефекаторы

3Строки символов

Номер 4

Составьте из символов f 4 5 .E a 9 по два примера лексических единиц:

1 целые числа

2 вещественые числа

3 индификаторы

4 строки символов

Номер 5

Напишите на языке Паскаля выражение:

2а (во второй степени)+с

- с (во второй ст)

а+5с

Номер 6

Написать программу ,которая находит пересмотр и площадь ,если с клавиатуры вводят длины сторон .

Показать ответ
Ответ:
valera228005
valera228005
03.09.2020 03:57
Uses crt;
const zn=[' ',':',',','!','?','-',';',')'];
var s,s1,s2:string;
i,k:byte;
begin
clrscr;
writeln('Введите строку, содержащую 2 одинаковых слова:');
readln(s);
s:=s+' ';
for i:=1 to length(s) do
if s[i] in zn then s[i]:=' ';
while pos(' ',s)>0 do
delete(s,pos(' ',s),1);
if s[1]=' ' then delete(s,1,1);
k:=0;
while pos(' ',s)>0 do
begin
s1:=copy(s,1,pos(' ',s)-1);
for i:=pos(' ',s)+1 to length(s) do
if (copy(s,i,length(s1))=s1)
and(s[i-1]=' ')
and((s[i+length(s1)]=' ')
or(i+length(s1)-1=length(s))) then
begin
k:=1;
s2:=s1;
write('Одинаковые слова ',s2);
readln;
exit;
end;
delete(s,1,pos(' ',s));
end;
if k=0 then write('Нет двух одинаковых слов');
readln
end.
0,0(0 оценок)
Ответ:
Лисана539
Лисана539
24.03.2021 23:06
1)Необходимы: данные задачи, условия, порядок действий.
2)Формы записи алгоритмов: графический (в виде блок-схемы), на естественном языке, на алгоритмическом языке, на языке программирования.
3)1. набрать в 9л-ое ведро полное и вылить из него в 5л-ое. освободить 5л-ое ведро.в 9л-ом останется 4 л.
2. переливает эти 4 л в 5л-ое ведро.
3. наполняет 9л-ое ведро и выливает в 5л-ое ещё 1 л. в 9л-ом остается 8 л. освобождает 5л-ое ведро.
4. переливает из9л-ого ведра 5 л. и в 9л-ом ведре остается ровно 3 л.
4)Геометрические фигуры в блок-схеме: овал - начало и конец алгоритма, прямоугольник - команды, параллелограмм - ввод и вывод данных, ромб - условие, шестиугольник - счетчик цикла.
5)Порядок выполнения отдельных действий в блок схеме задается в виде стрелок, соединяющих блоки.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота