В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fhshjshetubehdh
fhshjshetubehdh
09.10.2021 00:29 •  Информатика

Ни откуда не копировать!
Составьте программу решения квадратного уравнения с использованием подпрограммы-функции.

Показать ответ
Ответ:
lina160107
lina160107
13.10.2020 15:56

var a,b,c, x1,x2,D: real;

begin

writeln(' а,б,с : ');

readln(a,b,c);

D := b*b - 4*a*c;

if D<0 then writeln('нет ответа') ;

if D=0 then

begin

x1 := -b/2/a;

writeln('х1 : ',x1:0:3);

end;

if D>0 then

begin

x1 := (-b-sqrt(D))/2/a;

x2 := (-b+sqrt(D))/2/a;

writeln('х1 и х2: x1=',x1:0:3,' x2=',x2:0:3);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота