Необходимо написать программу в PascalABC, переводящую градусы по Фаренгейту в градусы по Цельсии (использовать условие - F = C * 1,8 + 32). Для переменных использовать "Real" вместо "Integer". Ниже прикреплю программу, получившуюся у меня (она, конечно, неверная). Задание оценивается в Program qq;
Uses crt;
Var F, C: Real;
Begin
Writeln ('Сколько градусов по Фаренгейту?');
Readln (F);
C:= F-32 div 2;
Writeln (',C, градусов Цельсия');
end.
#include <iostream>
#include <time.h>
#include <cstdlib>
using namespace std;
int main() {
int n, s = 0, max = 0, min = 9;
srand(time(NULL));
do {
cout << "Input size of matrix: n = ";
cin >> n;
if (n < 0)
{
cout << "Input error! n < 0. Please try again" << endl;
continue;
}
else break;
} while (true);
int **matr = new int* [n];
for(int i = 0; i < n; i++)
matr[i] = new int [n];
for (int i = 0; i < n; i++)
{
for (int j = 0; j < n;j++)
{
matr[i][j] = rand() % 10;
cout << matr[i][j] << " ";
}
cout << endl;
}
for (int i = 0; i < n; i++)
{
if (max < matr[i][i])
max = matr[i][i];
if (min > matr[i][n-i-1])
min = matr[i][n-i-1];
s += matr[i][i] + matr[i][n - i - 1];
}
if (n % 2 != 0)
s -= matr[n / 2][n / 2];
cout <<"Maximum number on the main diagonal: " << max << endl << "Minimum number on the secondary diagonal: " << min << endl << "Sum of numbers on the diagonals: " << s;
return 0;
}
/* Редактор не сохраняет отступы зачастую, поэтому прикрепил .cpp файл с кодом */
7 бит:
ASCII7 — первая кодировка, пригодная для работы с текстом. Помимо маленьких букв английского алфавита и служебных символов, содержит большие буквы английского языка, цифры, знаки препинания и другие символы.
Кодировки стандарта ASCII (8 бит):
ASCII — первая кодировка, в которой стало возможно использовать символы национальных алфавитов.
КОИ8-R — первая русская кодировка. Символы кириллицы расположены не в алфавитном порядке. Их разместили в верхнюю половину таблицы так, чтобы позиции кириллических символов соответствовали их фонетическим аналогам в английском алфавите. Это значит, что даже при потере старшего бита каждого символа, например, при проходе через устаревший семибитный модем, текст остается "читаемым".
CP866 — русская кодировка, использовавшаяся на компьютерах IBM в системе DOS.
Windows-1251 — русская кодировка, использовавшаяся в русскоязычных версиях операционной системы Windows в начале 90-х годов. Кириллические символы идут в алфавитном порядке. Содержит все символы, встречающиеся в типографике обычного текста (кроме знака ударения).