В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
hyrshkananastasiya
hyrshkananastasiya
11.11.2020 21:10 •  Информатика

Необходимо написать программу, которая проверяет, знаете ли вы таблицу умножения. Программа выводит на экран пример, ответ на который должен ввести пользователь. Программа должна вывести на экран, верно ли ответил пользователь, и показать правильный результат, если пользователь ответил неверно.
Генерируйте пример с генератора случайных чисел (random, randint)
Таблица умножения включает в себя числа от 1 до 9
В программе должно быть ветвление if

Показать ответ
Ответ:
Vova77723
Vova77723
27.08.2020 23:57

import random

while True:

       a = random.randint(1, 9)

       b = random.randint(1, 9)

       i = 0

       while True:

               try:

                       print("%dx%d=" % (a, b), end="")

                       i = int(input())

               except ValueError:

                       print("Введите число!")

               else:

                       break

       rightAnswer = a * b

       if i == rightAnswer:

               print("Верно!\n")

       else:

               print("Неверно! Верный ответ: %d\n" % rightAnswer)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота