не брать с интернета!
Именно составить новую программу!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер. В отчет включить программный код и результат работы программы в виде скриншота. Программная реализация обязательна.
ответ:
uses crt;
var s,sf,sl: string;
i,l: integer;
begin
writeln('введите слова: ');
readln(s);
if s[1]=' ' then //проверяем, чтобы не было пробелов в начале строки
repeat
delete(s,1,1); //удаляем пробелы в начале строки, если они есть
until s[1]< > ' ';
l: =length(s);
if s[l]=' ' then //проверяем, чтобы не было пробелов в конце строки
repeat
delete(s,l,1); //удаляем пробелы в начале строки, если они есть
dec(l);
until s[l]< > ' ';
i: =1;
sf: =''; sl: =''; //изначально переменные для первого и последнего слова пусты
while s[i]< > ' ' do //начинаем с первого символа и прекрепляем к первому слову
begin
sf: =sf+s[i]; //по одному символу до тех пор, пока не дойдем до пробела
inc(i); //увеличиваем счетчик символов на 1
end;
i: =l;
while s[i]< > ' ' do //начинаем с последнего символа и прекрепляем ко второму слову (спереди, то есмть по сути перед словом =))
begin
sl: =s[i]+sl; //по одному символу до тех пор, пока не дойдем до пробела
dec(i); //уменьшаем счетчик символов на 1
end;
writeln(sf,' ',sl); //вывод
readln;
end.
объяснение:
ответ:
брат такой ответ дал незнаю нащет правельно с и но может правельно)
c++выделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include
#include
#include
#include
#include
using namespace std;
void main()
{
setlocale(0, "");
srand(time(null));
int a[10] = {};
int b[5] = {};
int c[5] = {};
for (int i = 0, q = 0; i < 10; i++)
{
a[i] = rand() % (20 - (-20) + 1) + (-20);
cout < < a[i] < < endl;
if (a[i] % 2 == 0)
{
cout < < "" < < endl;
b[q] = a[i];