найти ошибку! Написать программу на СИ, запрашивающую у пользователя в бесконечном цикле число и выводящую среднее значение всех введённых ранее чисел. Вывод в формате: "Среднее значение этих ... чисел равно ...". Среднее значение выводить с точностью до 5 десятичных знаков (т.е. до 1/100000).
Программа перестаёт работать или при вводе символа вместо числа, или при истечении 1 минуты с момента ввода первого числа.
Или найти ошибку
#include // Библиотека для работы с функциями ввода-вывода
#include // Библиотека для указания локации (региональной кодировки)
#include // Библиотека математических функций
#include // Библиотека для работы с временем
int main() {
setlocale(LC_ALL, "Rus");
time_t start, end;
int timelim = 60;
int a = 0;
int i = 1, s;
float c;
start = time(NULL);
end = time(NULL);
for ( ; difftime(end, start) < timelim; end = time(NULL)) {
for (i = 1; i > 0; i++) {
printf("Введите число:\n");
scanf_s("%d", &s);
a += s
c = a / i;
if (scanf_s("%d", &s) < 1) {
printf("Только числа нужны нам. Ошибку допустил ты...\n");
return 0;
}
printf("Среднее значение этих %d чисел равно %.3f ", i, c);
}
printf("Ваше время истекло...\n");
printf("Пока!\n");
return 0;
}
Завершающий урок цикла "Первые шаги" посвятим изучению гироскопического датчика. Данный датчик, как и ультразвуковой, присутствует только в образовательной версии набора Lego mindstorms EV3. Тем не менее, пользователям домашней версии конструктора советуем тоже обратить внимание на данный урок. Возможно, что прочитав о назначении и использовании этого датчика, вы пожелаете его приобрести в дополнение к своему набору.
10.1. Изучаем гироскопический датчик
Гироскопический датчик (Рис. 1) предназначен для измерения угла вращения робота или скорости вращения. Сверху на корпусе датчика нанесены две стрелки, обозначающие плоскость, в которой работает датчик. Поэтому важно правильно установить датчик на робота. Также для более точного измерения крепление гироскопического датчика должно исключать его подвижность относительно корпуса робота. Даже во время прямолинейного движения робота гироскопический датчик может накапливать погрешность измерения угла и скорости вращения, поэтому непосредственно перед измерением следует осуществить сброс в 0 текущего показания датчика. Вращение робота против часовой стрелки формирует отрицательные значения измерений, а вращение по часовой стрелке - положительные.
Гироскопический датчик
Рис. 1
Рассмотрим программный блок "Гироскопический датчик" (Рис. 2) Желтой палитры. Этот программный блок имеет три режима работы: "Измерение", "Сравнение" и "Сброс". В режиме "Измерение" можно измерить "Угол", "Скорость" или одновременно "Угол и скорость".
Программный блок "Гироскопический датчик"
Рис. 2
Давайте закрепим гироскопический датчик на нашем роботе (Рис. 3), подсоединим его кабелем к порту 4 модуля EV3 и рассмотрим примеры использования.
1.цифровые датчики, генерирующие последовательность импульсов или двоичное слово; - бинарные датчики, которые вырабатывают сигнал только двух уровней: "включено/выключено"
2.Гироскопический датчик выполнить гораздо более точные движения.Задача состоит в том, чтобы запрограммировать своего робота на выполнение поворота на месте на точный угол, используя гироскопический датчик.
3.Гироскопический датчик предназначен для измерения угла вращения робота или скорости вращения. ... Поэтому важно правильно установить датчик на робота