В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
настя7585
настя7585
01.05.2021 02:42 •  Информатика

Народ, написать программу на vba. 1. даны два действительных числа x и y. если наименьшее из них отрицательно, то заменить его нулем, в противном случае единицей. 2. даны целые числа a1, a2, an. вычислить s=1/a1+1/(a1+a2)++1/(a1+a2++an)

Показать ответ
Ответ:
habibullina342
habibullina342
31.01.2020 00:50

using System;

namespace restless

{

   class Program

   {

       static void Main()

       {

           int x = Convert.ToInt32(Console.ReadLine());

           int _counter = x.ToString().Length;

           bool IsEven = (x & 1) == 0 ? true : false;

           if (_counter == 1 && IsEven)

               Console.WriteLine("Четное однозначное число");

           else if (_counter == 1 && !IsEven)

               Console.WriteLine("Нечётное однозначное число");

           

           else if (_counter == 2 && IsEven)

               Console.WriteLine("Чётное двузначное число");

           else if (_counter == 2 && !IsEven)

               Console.WriteLine("Нечётное двузначное число");

           

           else if (_counter == 3 && IsEven)

               Console.WriteLine("Чётное трехзначное число");

           else if (_counter == 3 && !IsEven)

               Console.WriteLine("Нечётное трехзначное число");

       }

   }

}

0,0(0 оценок)
Ответ:
zzzPhenomenalOnezzz
zzzPhenomenalOnezzz
28.07.2021 07:25

Во время ВОВ сложные технические и криптографические средства зашиты информации стали во многом ключевыми, ведь ценность информации возросла кратно. К июню 1941, когда немецкие армии вторглись на территорию СССР, наша система защиты государственной тайны была практически полностью сформирована. Она успешно выполняла целый ряд поставленных перед ней задач. От любых иностранных разведок надежно защищались все информационные ресурсы: мобилизационные, технические, военные, политические, идеологические и природные.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота