В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
myyyrrr
myyyrrr
17.11.2020 15:03 •  Информатика

Нарисуйте блок-схему и напишите программу для исполнителя, которая вычисляет значение функции. выполните 2-мя с неполного условия и вложенного ветвления.

Показать ответ
Ответ:
ВикаКотик283627
ВикаКотик283627
31.01.2023 08:01

Объяснение:

using System;

   class Program

   {

       static void Main(string[] args)

       {

           long n, m;

           n = long.Parse(Console.ReadLine());

           m = long.Parse(Console.ReadLine());

           long[,] mas = new long[n,m];

           for(long i = 0; i < n; i++)

           {

               for (long j = 0; j < m; j++)

               {

                   mas[i, j] = long.Parse(Console.ReadLine());

               }

           }

           long s=mas[0,0];

           mas[0, 0] = mas[n - 1, m - 1];

           mas[n - 1, m - 1] = s;

           for (long i = 0; i < n; i++)

           {

               for (long j = 0; j < m; j++)

               {

                   Console.Write(mas[i, j] + " ");

               }

               Console.WriteLine();

           }

           Console.ReadLine();

       }

   }

тут без namespace

0,0(0 оценок)
Ответ:
анастасия1548
анастасия1548
10.12.2020 00:03

#include <iostream>

#include <vector>

#include <cmath>

#include <set>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   set<pair<int,int>> s;

   int n;

   cin >> n;

   vector<int> a(n);

   for(int &i:a)

       cin >> i;

   int m;

   cin >> m;

   while(m--){

       int x,y;

       cin >> x >> y;

       s.insert({x,y});

       s.insert({y,x});

   }

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a[j] > a[j+1] && s.find({a[j],a[j+1]}) == s.end())

               swap(a[j],a[j+1]);

   for(int &i:a)

       cout << i << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота