В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yulokkons
yulokkons
27.05.2023 03:56 •  Информатика

нарисовать блок схему по данному заданию Составить программу упорядочивания трех чисел x, y, z по возрастанию.
если что вот алгоритм программы
var x, y, z : integer;
begin
Writeln('Введите значения X Y Z: ');
Readln(x, y, z);
if x > Y then
begin
x := x + Y;
x := x - Y;
x := x - Y;
end;
if Y > Z then
begin
Y := y + z;
z := Y - z;
y := y - z;
end;
if x > y then
begin
x := x + y;
y := x - y;
x := x - y;
end;
writeln('X=',x, 'Y=',y, 'Z=',z);
end.

Показать ответ
Ответ:
alecsandrkozevn
alecsandrkozevn
07.06.2020 04:25

В систему наук входят различные по возрасту дисциплины. Науки, которые появились во 2-ой половине 20 века (генетика, лингвистика), те что появились (?) в эпоху Возрождения (механика), в Новое Время, из Античности (география).

Классификацией наук называется метод выявления структуры частных разделов знаний и множества входящих в них отдельных дисциплин на основе какого-либо критерия, который раскрывает логически обоснованное расположение дисциплин в отдельный ряд.

Аристотель, ... Кант, Энгельс, Вильденбард, Вернадский, Кед занимались классификацией.

Универсальной классификации нет.

1. Всю систему наук можно условно подразделить на большие группы или подсистемы:

1.1. Естественные.

1.2. Общественные.

1.3. Технические.

1.4. Гуманитарные.

1.5 Логико-математичекие науки.

Каждая из этих подсистем отличаются своим предметом и методом. Каждая из подсистем образует отрасли разнообразным образом скоординированных наук. Например, в подсистему естественных наук входят отрасли: механика, физика, химия, биология. Общественные науки, то подсистема состоит из отраслей: социология, экономика, политология и т.д. В свою очередь, каждая из отраслей подразделяется на научные дисциплины: биофизика, физическая химия, социальная философия, менеджмент, экономика малого и среднего бизнеса.

2. Резких граней между указанными подсистемами нет, многие занимают промежуточное положение. И учитывая эти трудности, прибегают к иной классификации, где к основным подсистемам относят:

2.1. Обществознание.

2.2. Естествознание.

2.3. Логико-математические науки.

2.4. Современные комплексные отрасли - кибернетика, синергетика, семиотика.

В обществознание включена экономическая отрасль, социальная, техническая (т.к. продукт человеческой деятельности), гуманитарная и антропологическая.

Антропологические: педагогика, медицина, философская антропология.

Современные комплексные науки: 50е года - кибернентика, системный анализ и системология, экология, информатика, информалогия и информалистика (более общие), синергетика, ритмология - наука о …, симметриология - о повторяемости и со.., оптимология, глобалистика, коэволюция, космогенез.

3. Другая классификация - разделение всех наук на фундаментальные и прикладные по удалённости от практики.

 

Специфика естественно научного и социально-гуманитарного познания.

Оба вида возникли на определённом этапе когда:

1. Эти области стали зрелыми.

2. Достаточно развитое их соотношение.

Такая ситуация сложилась во второй половине 20 века и 21 веке.

В это время происходит признание среди учёных социально гуманитарного знания в качестве самостоятельного научного направления. До этого не относились к науке вообще (психология, социология, педагогика, т.к. там мало математики).

Это признание связано с тремя факторами:

1. Интенсивное развитие социальных и гуманитарных наук, усиление их роли в осмыслении проблем человеческого существования.

Например, герменевтика, социология, палеонтология.

2. Разработка собственных принципов и методов социо-гуманитарного познания.

3. Осознание ответственности учёных за последствия результатов своей научной деятельности (не опасно ли дальше вести исследование в генетике и т.п. - биоэтика, экологическая этика).

Специфика социо-гуманитарного знания.

Например, раскрыть специфику яблока - указать чем оно отличается от груши.

1. Субъектно-объектное (С-О) отношения к познавательному процессу.

Есть субъект и его объект.

Специфичность объекта:

1.1. Объектом выступает общество, культура и человек (человеческая деятельность её формы и результат).

1.2. Законы общества, в отличие от законов природы, создаются людьми. Они связаны с повседневной жизнью людей и общества, но могут не осознаваться людьми.

1.3. Законы общества и культуры менее долговечны, чем законы природы (они историчны), ограничены временем и этапом существования общества. Например политические законы (перестройка в России). Напротив, законы природы либо вечные, либо долговременно действующие.

1.4. По своему объекту социально-гуманитарное знание обращено к сознательной деятельности людей, а в природе законы действуют спонтанно, независимо от человеческого сознания.

Учёный обществовед находится в такой ситуации, что процессы и люди, которые он изучает, меняются (взгляды, интересы, мотивы). Эти науки сложнее для изучения, чем природа (это в общем бредятинка, но встречается в учебниках). Поэтому познание диалогично, а в  естественных науках монологично.

Объект не только познаётся, но и оценивается субъектом. Это придаёт познанию ценностно-оценочный характер, а критерий оценки всегда различен.

Критерий оценки связан с нормами, идеалами... (?) учет степени свободы личности, устремлённость к демократии или автократии.

Об

0,0(0 оценок)
Ответ:
murplushka
murplushka
03.12.2020 09:53

16

Объяснение:

1. Алфавит мощностью 26 символов требует для кодирования символа 5 бит (2⁴ < 26 < 2⁵). 22 символа займут 22×5 = 110 бит = 110 / 8 = 13.75 байта, округляем до целого вверх, получаем 14 байт.

2. Номер года обозначается одним из 100 чисел. 2⁶ < 100 > 2⁷, поэтому для кодирования требуется 7 бит.

3. Номер для обозначается одним из 366 чисел. 2⁸ < 366 > 2⁹, поэтому для кодирования требуется 9 бит.

4. Всего для кодирования срока действия потребуется 7+9 = 16 бит = 16/2 = 2 байта

5. Вся информация на пропуске займет 14+2 = 16 байт

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота