нарисовать блок схему алгоритма и написать программу, в которой вручную задаётся массив размеров [3 x 4] затем он выводиться на экран и рассчитывается сумма элементов массива и выводиться на экран по инфе
әріп түрінде немесе әріптер тобы түрінде программаға енгізілетін және уақыт, ұзындық, баға, түс және т.б. әр түрлі мәндерді қабылдайтын программадагы сандық шама;
белгілі бір мәліметтер типін сақтай алатын және программаны атқару барысында мәнін өзгертуге болатын атауы белгілі объект.
[1]
Айнымалылар әдетте кіші латын немесе грек әріптерімен (индекстерімен болуы мүмкінами) белгіленеді: {\displaystyle x,~y,~\varepsilon }{\displaystyle x,~y,~\varepsilon }.
Өзгеру облысы айнымалылардың сәйкес әріптермен, бірақ ирек жақшамен алынып белгіленеді: {\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}{\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}.
Айнымалы және тұрақты шама
А й н ы м а л ы шама — әр түрлі сан мәндерін қабылдайтын шама. Ал сан мәні өзгеріссіз қалатын шама т ұ р а қ т ы шама деп аталады. Дегенмен айнымалы шама мен тұрақты шаманың арасындағы айырмашылық салыстырмалы түрде болады. Өйткені кейбір мәселедегі тұрақты шама, басқа бір жағдайда айнымалы шама болуы мүмкін.
Айнымалы шаманы математикаға енгізіп, оны жүйелі түрде зерттеуді бастаған француз ғалымы Рене Декарт (1596 — 1650) болды. Айнымалы шаманың негізінде өзгеріс пен қозғалыс жатыр. Сондықтан тұрақты шама математикасынан айнымалы шама математикасына көшу ғылыми ойлаудағы үлкен төңкеріс болды. Сөйтіп, интегралдық және дифференциалдық есептеу әдістері арқылы процестер мен өзгерістерді зерттеуге мүмкіндік жасалды. Кейде айнымалы шамалар арасындағы байланысты функция деп те атайды. Математика онан әрі дамыған сайын зерттелетін функциялар саны да көбеюде.[2]
Тәуелсіз және тәуелді
Зерттелетін мәселелерде бірден артық айнымалылар болса тәуелсіз және тәуелді айнымалыларға ажыратылады.Тәуелді айнымалылар тәуелсіз айнымалылардың(аргументтердің) функциясы ретінде қарастырылады.Жоғарыда мысалға келтірілген қозғалыста, егер h биіктіктің t уақытқа тәуелділігі зерттелетін болса, онда тәуелсіз айнымалы - t уақыт болып есептеледі, ал тәуелді айнымалы t-ның функциясы - h биіктік болады; егер жылдамдықтың биіктікке тәуелділігі зерттелетін болса, онда биіктік тәуелсіз айнымалы, ал жылдамдық h-тың функциясы болады.Сонымен, айнымалы тек бір-біріне ғана қатысты тәуелді немесе тәуелсіз болады, бұлардың айырмашылығы есептің
var a: string;
begin
write ('Введите слово: '); read (a);
writeln ('Именительный падеж: ',copy(a,1,length(a)));
writeln ('Родительный падеж: ',copy(a,1,length(a)-1),'ы');
writeln ('Дательный падеж: ',copy(a,1,length(a)-1),'е');
writeln ('Винительный падеж: ',copy(a,1,length(a)-1),'у');
writeln ('Творительный падеж: ',copy(a,1,length(a)-1),'ой');
writeln ('Предложный падеж: ',copy(a,1,length(a)-1),'е');
end.
Основной момент, это удаление окончания путем копирования слова в строке a начиная с первого символа, до длины слова минус 1 символ.
Объяснение:
Айнымалы —
әріп түрінде немесе әріптер тобы түрінде программаға енгізілетін және уақыт, ұзындық, баға, түс және т.б. әр түрлі мәндерді қабылдайтын программадагы сандық шама;
белгілі бір мәліметтер типін сақтай алатын және программаны атқару барысында мәнін өзгертуге болатын атауы белгілі объект.
[1]
Айнымалылар әдетте кіші латын немесе грек әріптерімен (индекстерімен болуы мүмкінами) белгіленеді: {\displaystyle x,~y,~\varepsilon }{\displaystyle x,~y,~\varepsilon }.
Өзгеру облысы айнымалылардың сәйкес әріптермен, бірақ ирек жақшамен алынып белгіленеді: {\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}{\displaystyle \left\{x\right\},~\left\{y\right\},~\left\{\varepsilon \right\}}.
Айнымалы және тұрақты шама
А й н ы м а л ы шама — әр түрлі сан мәндерін қабылдайтын шама. Ал сан мәні өзгеріссіз қалатын шама т ұ р а қ т ы шама деп аталады. Дегенмен айнымалы шама мен тұрақты шаманың арасындағы айырмашылық салыстырмалы түрде болады. Өйткені кейбір мәселедегі тұрақты шама, басқа бір жағдайда айнымалы шама болуы мүмкін.
Айнымалы шаманы математикаға енгізіп, оны жүйелі түрде зерттеуді бастаған француз ғалымы Рене Декарт (1596 — 1650) болды. Айнымалы шаманың негізінде өзгеріс пен қозғалыс жатыр. Сондықтан тұрақты шама математикасынан айнымалы шама математикасына көшу ғылыми ойлаудағы үлкен төңкеріс болды. Сөйтіп, интегралдық және дифференциалдық есептеу әдістері арқылы процестер мен өзгерістерді зерттеуге мүмкіндік жасалды. Кейде айнымалы шамалар арасындағы байланысты функция деп те атайды. Математика онан әрі дамыған сайын зерттелетін функциялар саны да көбеюде.[2]
Тәуелсіз және тәуелді
Зерттелетін мәселелерде бірден артық айнымалылар болса тәуелсіз және тәуелді айнымалыларға ажыратылады.Тәуелді айнымалылар тәуелсіз айнымалылардың(аргументтердің) функциясы ретінде қарастырылады.Жоғарыда мысалға келтірілген қозғалыста, егер h биіктіктің t уақытқа тәуелділігі зерттелетін болса, онда тәуелсіз айнымалы - t уақыт болып есептеледі, ал тәуелді айнымалы t-ның функциясы - h биіктік болады; егер жылдамдықтың биіктікке тәуелділігі зерттелетін болса, онда биіктік тәуелсіз айнымалы, ал жылдамдық h-тың функциясы болады.Сонымен, айнымалы тек бір-біріне ғана қатысты тәуелді немесе тәуелсіз болады, бұлардың айырмашылығы есептің
Объяснение:
вот