В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikzarubenko
nikzarubenko
02.08.2022 02:39 •  Информатика

Напишите рекурсивную программу, которая по заданным A и B

вычисляет целую часть от деления A/B.

Входные данные

Два натуральных числа A и B.

Выходные данные

Выдать значение в формате:

div(,)=<значение>

НАписать на ПИТОНЕ

Показать ответ
Ответ:
embazuka
embazuka
01.02.2022 19:03
1. Начнём с понятий:
- Равнобедренный треугольник - это треугольник, у которого две стороны равны между собой.
- Равносторонний треугольник - это треугольник, у которого все стороны равны между собой.
- Разносторонний треугольник - это треугольник, у которого все стороны имеют разную длину.

2. Составим алгоритм программы:
(см. рисунок).

3. Напишем программу, которая будет определять, является ли треугольник: равнобедренным, равносторонним или разносторонним:

var a,b,c: Integer;
begin
writeln('Введите длину стороны a');
readln(a);
writeln('Введите длину стороны b');
readln(b);
writeln('Введите длину стороны c');
readln(c);
if (a=b) and (a=c) and (b=c) then writeln('Треугольник - равносторонний') else
if (a<>b) and (a<>c) and (b<>c) then writeln('Треугольник - разносторонний') else
writeln('Треугольник равнобедренный');
end.
Даны стороны треугольника опредилить и вывести на экран, выяснить является ли он равно бедренным, ра
0,0(0 оценок)
Ответ:
bhgd
bhgd
31.10.2020 17:23
Задача 1.
1. Находим количество точек (пикселей) в кадре 640×480 = 307200
2. Находим размер палитры 250×1024×8/307200 = 6 бит (отбрасываем дробную часть после деления)
3. Количество цветов в палитре не может превышать 2⁶ = 64

Пояснение: 250 Кбайт = 250×1024 байт = 250×1024×8 бит.

Задача 2.
1. Находим объем исходной палитры
256 = 2⁸, поэтому объем составит 8 бит
2. Находим объем новой палитры
2=2¹, поэтому объем составит 1 бит.
3. Находим, во сколько раз уменьшится объем файла
8/1=8 - в восемь раз.
4. Если первоначальный объем был Х, то новый станет Х/8. Уменьшение объема составит X-X/8 = 7X/8 и это равно 7 Кбайт.
Тогда 7Х=7*8 Кбайт, откуда Х=8 Кбайт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота