Напишите программы на Паскале.
Из трёх данных вещественных чисел R, M, Y выбрать наибольшее и вывести его на экран. Числа R, M, Y ввести с клавиатуры с оператора ввода.
Напишите программу решения уравнения ax + b = 0, где a и b — заданные действительные числа, любое из которых может равняться нулю. ответ выведите с точностью до тысячных.
В отчет включить текст программ, реакцию ЭВМ.
функция input предназначена для того, чтобы ты из консоли мог давать значение переменной после запуска своей проги. Если ты хочешь, чтобы твоя прога сама предлага вводить параметры а, b, c то стери что в скобке input или напиши так:
a=int(input('a = '))
b=int(input('b = '))
c=int(input('c = '))
и уже как запустишь свою прогу в консоли надо дописать, чему будет равны а, b, c. Или в своей проге укажи чему равны параметры а, b, c. Например:
a=1
b=2
c=3
если тебе нужны только целые числа, округленные в наименьшое целое чилсо, то используй функцию int. Например
a=int(5.9)
print(a)
будет напечатано 5
Объяснение:
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
uses System.Linq;
begin
writeln('III');
var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;
writeln;
while a.Any() do
begin
write(a[0], ' ');
a.RemoveAt(0);
if not a.Any then break;
write(a.Last, ' ');
a.RemoveAt(a.Count - 1);
if not a.Any then break;
var n := 0;
if a.Count > 1 then n := a.Count div 2 - 1;
write(a[n], ' ');
a.RemoveAt(n);
end;
end.
Объяснение: