Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
marialkahelp
07.03.2023 05:00 •
Информатика
Напишите программы для решения .используя div и mod дана масса в граммах.переведите ее в килограммы и граммы
Показать ответ
Ответ:
zvonilovakarina
07.10.2020 21:19
Var
m,k,g:integer;
begin
Write('Введите массу в граммах: '); Read(m);
k:=m div 1000;
g:=m mod 1000;
Writeln(m,' г = ',k,' кг ',g,' г')
end.
Пример
Введите массу в граммах: 23521
23521 г = 23 кг 521 г
0,0
(0 оценок)
Популярные вопросы: Информатика
suleymanovrusl
15.05.2021 00:54
Дана последовательность чисел 1, 4, 7, 10, 13, считать сумму всех элементов этой последовательности до тех пор пока она не достигнет 1000...
kosta292006
15.05.2021 00:54
Нужно решить через паскаль с циклов for или while 1)известно количество пассажиров за каждый месяц. вычислить ср. арифметическое за год 2)известно кол-во очков каждого игрока...
gigi24
12.07.2020 09:26
Найти максимальное из трех неравных чисел и присвоить ему имя max...
coroleovacarina2013
12.07.2020 09:26
Склавиатуры вводится натуральное число n. найдите и выведите самую большую цифру этого числа....
Sofwork
12.07.2020 09:26
Составить программу в pascal 1)в строке , введенной с клавиатуры , все буквы и заменить на % 2)из строки, введенной с клавиатуры , удалить все символы ,начиная с середины....
karallisa
13.07.2021 20:41
100 .напишите программу перевода числа из восьмеричной системы счисления в двоичную. оформить в паскале....
mashkasuper1
24.02.2020 14:28
Ақпарат саны 300 биттен тұратын хабарламада 100 символ бар алфавит куаттылыгы канша...
Littlelimegirl
13.02.2020 11:23
Рассмотри картинку. Определи, что за устройство изображено на ней...
папа1231
26.07.2020 22:24
Кодируется числом 25. Потому что буква и находится пересечении 2-й строки и 5-го столбца. Составь слоПереведи на русский язык слова под номером 3 и 5. Назови1.11 32 15 36...
dyadyan
03.04.2023 02:16
Зашифруй кодом Цезаря с шагом 5 слово ИНФОРМАТИКА *...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
m,k,g:integer;
begin
Write('Введите массу в граммах: '); Read(m);
k:=m div 1000;
g:=m mod 1000;
Writeln(m,' г = ',k,' кг ',g,' г')
end.
Пример
Введите массу в граммах: 23521
23521 г = 23 кг 521 г