В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
elsem78
elsem78
23.08.2022 07:52 •  Информатика

Напишите программу заполнения массива из 20 элементов случайными числами в диапозоне от -150 до 1000. найдите количество элементов, которые имеют нечетное значение и делятся на пять.

Показать ответ
Ответ:
MAK222222
MAK222222
19.07.2020 19:54
Var a:array[1..20] of integer;
    n,i:integer;
begin
for i:=1 to 20 do begin
  a[i]:=random(-150,1000);
  if (a[i] mod 5=0) and (a[i] mod 2<>0) then n+=1;
  write(a[i],' ');
end;
writeln();
writeln('Искомых элементов: ',n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота