В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Gir9
Gir9
04.01.2022 20:58 •  Информатика

Напишите программу, записывающую цвета разных песчаных морей. Формат ввода
Вводятся названия морей, пока не будет введена пустая строка. Потом вводится количество цветов песка, затем сами цвета.
Формат вывода
Для каждого моря через * запишите все цвета, с которыми у этого моря есть общие буквы, если не обращать внимание на регистр, и длины имеют не совпадающую четность. Цвета записывайте после названия моря через символ &, без повторений. Название моря большими буквами.
Если подходящих цветов для моря не нашлось, то его не выводить. Порядок вывода морей и цветов не важен.
Пример 1
Ввод Вывод
Red
Sandy
grassy
sea of grain

6
white
dark brick
yellowish
gray
volcanic
red

SEA OF GRAIN&red*yellowish*white
SANDY&dark brick*gray*volcanic
RED&dark brick*gray
GRASSY&yellowish*red

Пример 2
Ввод Вывод
mighty
tiny
Green

4
black
brown
pinkish
lemon

Показать ответ
Ответ:
daniela07
daniela07
25.04.2021 00:27
Var
  dc:set of char;
  s1,s2:string;
  i:integer;
begin
  dc:=['A'..'D','a'..'d'];
  s1:='То avoid the impression of the tail wagging the dog, '+
    'the president cannot be seen bending to the wishes of a minority.';
  s2:='';
  for i:=1 to length(s1) do
    if not(s1[i] in dc) then s2:=s2+s1[i];
  Writeln('Исходная строка: ',s1);
  s1:=s2;
  Writeln('Результирующая строка: ',s1)
end.

Тестовое решение:
Исходная строка: То avoid the impression of the tail wagging the dog, the president cannot be seen bending to the wishes of a minority.
Результирующая строка: То voi the impression of the til wgging the og, the presient nnot e seen ening to the wishes of  minority.
0,0(0 оценок)
Ответ:
fdsufsycdst
fdsufsycdst
06.08.2022 21:40
Для перевода из двоичной в шестнадцатеричный надо код разделить на тетрады (на группы по 4 цифры):
0101 1101 1000 1010 1010 1111 0010 1010
Если слева недостаточно цифр до тетрады, то слева добавляем нули.
Далее переводим тетрады в шестнадцатеричный код с таблицы:
0000 => 0        0001 => 1        0010 => 2        0011 => 3        0100 => 4
0101 => 5        0110 => 6        0111 => 7        1000 => 8        1001 => 9
1010 => A       1011 => B        1100 => C       1101 => D        1110 => E
1111 => F
0101 1101 1000 1010 1010 1111 0010 1010 = 5D8AAF2A

Для перевода в восьмеричный код делаем аналогично, только на двоичный код делим на группы по 3 цифры:
001 011 101 100 010 101 010 111 100 101 010
И также если не хватает до 3-ех цифр, то слева добавляем нули.
Затем переводим по аналогичной таблице:
000 => 0      001 => 1      010 => 2      011 => 3
100 => 4      101 => 5      110 => 6      111 => 7
001 011 101 100 010 101 010 111 100 101 010 = 13542527452
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота