В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу вычисления значения функции y=6x+3 для любого значения х

Показать ответ
Ответ:
Редискa
Редискa
08.07.2022 13:47
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        // Дан массив С1, С2, …, С24. В массиве есть два элемента равные 0. Заменить все элементы, стоящие между ними, на единицы
        static void Main(string[] args)
        {
            const int n = 24; // Размер массива
            int[] С = new int[n]; // Создали массив
            for (int i = 0; i < n; i++) // Вводим элементы массива
            {
                С[i] = int.Parse(Console.ReadLine());
            }

            bool check = false; // Индикатор замены (пока что выключен)

            for (int i = 0; i < n; i++) // Цикл для выполнения замены
            {
                if (С[i] == 0) // Если проверемый элемент нулевой, то переулючить индикатор замены и закончить текущую иттерацию
                {
                    check = !check;
                    continue;
                }
                if (check == true) // Если индикатор замены включен, то заменяем текущий элемент
                    С[i] = 1;
            }

            for (int i = 0; i < n; i++) // Выводим элементы массива
            {
                Console.WriteLine(С[i]);
            }

            Console.ReadKey(); // Ждем нажатия клавиши
        }
    }
}
0,0(0 оценок)
Ответ:
nurlan27
nurlan27
10.10.2021 22:45
1. Определим размер файла, содержащего 1с записи.
Частота дискретизации по времени 16 кГц означает, что за 1с снимаются 16000 отсчетов громкости в каждом канале, а всего 4×16000=64000 отсчетов..
Частота дискретизации по уровню громкости (разрешение) составляет 32 бита или 32/8=4 байта и поэтому файл запись потребует для хранения одной секунды 64000×8=512000 байт = 512000/1024 = 500 Кбайт.
2. Найдем время записи
60 Мбайт = 60×1024 = 61440 Кбайт - общий объем файла
61440/500 = 122.88 с = 2 мин 2.88 с

ответ: а) 2 мин.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота