В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Майя123
Майя123
04.11.2021 15:11 •  Информатика

Напишите программу вычисления произведения ненулевых эл. массива. Проверьте работу программы {7, 25, 4.5, 0, 17, 61, - 10, 0, 1, - 4, 22}.
Произведения ненулевых эл равно:...

Показать ответ
Ответ:
tchasikova2018
tchasikova2018
14.10.2020 03:48

using System;

using System.Collections.Generic;

using System.Linq;

namespace Prog

{

   class Program

   {

       static void Main(string[] args)

       {

           List<double> array = new List<double>() { 7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22 };

           // TASK 5

           int positive, negative, zero;

           var tmp = array.FindAll(x => x > 0);

           positive = tmp.Count;

           tmp = array.FindAll(x => x == 0);

           zero = tmp.Count;

           negative = array.Count - zero - positive;

           Console.WriteLine($"Кол-во полож. элементов: {positive}\n\rКол-во нулевых элементов: {zero}\n\rКол-во отриц. элементов: {negative}");

           // TASK 6  

           double prv = 1;

           for (int i = 0; i < array.Count; ++i)

           {

               if (array[i] != 0)

               {

                   prv *= array[i];

               }

           }

           Console.WriteLine($"Произведение ненулевых элементов равно: {prv}");

           Console.ReadKey();

       }

   }

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота