В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
konotopnastya
konotopnastya
19.09.2020 18:43 •  Информатика

Напишите программу ввода значений r , y. в одной строке и выведите результат вычисления выражения r*y² +(y/5) в той же строке​

Показать ответ
Ответ:
кристина2161
кристина2161
27.03.2022 15:09
1) program fagasg;
var a,b,c,d: integer;
begin
Writeln('Введите первое число');
readln(a);
Writeln('Введите второе число');
readln(b);
Writeln('Введите третье число');
readln(c);
d:=0;
If a>0 then d:=d+1;
If b>0 then d:=d+1;
If c>0 then d:=d+1;
Writeln('Количество положительных чисел:',d);
end.
2) program gsggdfd;
var n,s,i: integer;
begin
writeln('Введите n');
readln(n);
s:=0;
For i:=1 to n do 
S:=s+i;
Writeln('Сумма последовательности равна:',s);
end.
3)Program afsdgf;
var A: Array[1..100] of integer;   
i,h,s,l: integer;
begin 
Writeln('ведите размер массива'); 
readln(h); 
s:=1; 
l:=1; 
For i:=1 to h do   
begin     
A[i]:=s+l;     
s:=s+2;     
writeln(A[i]);     
l:=A[i];   
end;
end.
0,0(0 оценок)
Ответ:
AndrewLoveRem
AndrewLoveRem
04.06.2023 16:23
Поскольку за последним словом в предложении пробела нет, то количество слов в предложении будет на единицу больше количества пробелов.

var
  i,n:integer;
  s:string;
begin
  Writeln('Введите текст, разделяя слова ровно одним пробелом');
  Readln(s);
  n:=0;
  for i:=1 to Length(s) do
    if s[i]=' ' then Inc(n);
  Writeln('Количество слов в тексте равно ',n+1)
end.

Тестовое решение:
Введите текст, разделяя слова ровно одним пробелом
Это текст, количество слов в котором нам нужно посчитать.
Количество слов в тексте равно 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота