В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vinerxasanzyan
vinerxasanzyan
13.02.2023 19:45 •  Информатика

Напишите программу ввести два натуральных числа n и m . если m > n , то вывести m − n строк, в каждой строке выводятся числа от n до m число раз, соответствующее выводимому числу. например, для n = 3 и m = 6: 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6

Показать ответ
Ответ:
ира1014
ира1014
08.09.2020 13:58
Var m,n,i,j:longint;
begin
readln(n,m);
if m > n then begin
for i:= n to m do begin
for j:= 1 to i do begin
write(i,' ');
end;
writeln;
end;
end else begin
for i:= m to n do begin
for j:= 1 to i do begin
write(i,' ');
end;
writeln;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота