Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
NekitGame225
05.10.2020 10:25 •
Информатика
Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.
Показать ответ
Ответ:
LinaPozniak08
01.10.2020 23:51
Var
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ladyviktoria
10.03.2023 19:05
Количество нулей в числе Дано натуральное число N. Напишите программу, определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N (1 ≤...
odimaa1dimas
24.12.2021 05:03
В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая – к адресу самого узла в этой...
fasio46
06.06.2020 21:57
Автомат обрабатывает натуральное трёхзначное число N по следующему алгоритму: 1. Из цифр, образующих десятичную запись N, строятся наибольшее и наименьшее возможные двузначные...
elkaE
24.12.2022 19:46
Напишите программу на паскале ! нужно найти строчку в тексте(в txt файле) с одного или более слов и потом эту строчку нужно разбить на слова в столбик...
logpol40
04.05.2020 20:51
Построить блок-схему и написать код программы на кумир для сортировки массива и нахождения количества раличных чисел в нем?...
ariana201723
11.03.2021 14:23
Проверьте, достаточна ли для устойчивой передачи данных мощность передатчика в 40 дБм, если длина кабеля равна 60 км, погонное затухание кабеля составляет 0,2 дБ/км, а порог...
СвятойТапочек
19.12.2021 02:42
Напишите код на паскале. сама : посчитать частоту встречаемости каждой буквы алфавита в введенном тексте....
Murmurvk
21.06.2021 13:13
Промышленный робот нужен для чего ?...
Vbeker
05.12.2022 01:53
Присваивать переменной P значение 4, если четыре заданные числа равны между собой, 3 - если три числа из заданных четырех равны между собой, 2 - если два числа из заданных четырех...
lena29091
18.02.2022 11:06
Переменная это - Комплекс программных средств, используемые программистами для разработки программногообеспечение поПоследовательность действий, которая направлена на достижение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.