В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
misspotter
misspotter
27.04.2021 07:14 •  Информатика

Напишите программу,в Python которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года», «25 лет».

Пример:

Введите возраст: 18
Вам 18 лет.

Пример:

Введите возраст: 21
Вам 21 год.

Пример:

Введите возраст: 22
Вам 22 года.

Показать ответ
Ответ:
290429
290429
12.10.2020 22:27

while True:

   try:

       age = int(input('Сколько вам лет?\n>> '))

       if 1 < age <= 120:

           break

       else:

           print('Введи возраст в диапазоне 0-120')

   except ValueError:

       print('Введи число!')

if 5 <= age <= 20:

   print(f'Вам {age} лет')

elif str(age)[-1] == '1':

   print(f'Вам {age} год')

elif 1 < int(str(age)[-1]) < 5:

   print(f'Вам {age} года')

elif 4 < int(str(age)[-1]) <= 9 or int(str(age)[-1]) == 0:

   print(f'Вам {age} лет')

Объяснение:

Python 3.8.2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота