В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sofisnow0826
sofisnow0826
26.12.2022 19:15 •  Информатика

Напишите программу в питоне получите случайное вещественное число в диапазоне от 0.10 до 0.50 . вывидите его на экран с двумя знаками после запятой

Показать ответ
Ответ:
alinabugajcuk38
alinabugajcuk38
25.01.2020 22:40
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Ответ:
KNEZIX
KNEZIX
08.06.2022 13:46

program pr10;

uses crt;

var

  i: integer;

  t: real; // рабочая переменная

  i: byte; // счетчик массива

  k: byte; // параметр цикла

  a: array[1..15] of real;

  n: byte; // размерность цикла

begin

  clrscr;

  write('введите размерность: ');

  readln(n);

  writeln('введите ',n,' элементов');

  for i: =1 to n do

      readln(a[i]);

      writeln('исходный массив: ');

  for i: =1 to n do

      write(a[i]: 5: 1,' ');

      readln;

// блок обработки

  for k: =1 to n do

      for i: =1 to n-k do

        if(a[i]> a[i+1]) then

// перестановка

            begin

              t: =a[i];

              a[i]: =a[i+1];

              a[i+1]: =t;

            end;

  writeln('отсортированный массив: ');

  for i: =1 to n do

      write(a[i],' ');

      writeln;

      readln;

end.

я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота