В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tsukankova02mail
tsukankova02mail
19.02.2022 11:06 •  Информатика

Напишите программу в Питоне, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.

Показать ответ
Ответ:
DashkaaMilashka
DashkaaMilashka
15.10.2020 12:38

print(sum([i for i in [int(input()) for _ in range(int(input()))] if i % 6 == 0]))

0,0(0 оценок)
Ответ:
Aloha44
Aloha44
15.10.2020 12:38

--- Python 3.7.0 ---

def ReadSeq(SeqLen: int, CastType):

  for _ in range(SeqLen):

      yield CastType(input())

def main():

   RawSequence = ReadSeq(int(input()), int)

   Selector = lambda item: (item % 6 == 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Res: {sum( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота