В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alenushka73
alenushka73
27.12.2021 08:44 •  Информатика

Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.

Показать ответ
Ответ:
atodyshevoxz3kh
atodyshevoxz3kh
15.10.2020 12:39

вот.............................

Объяснение:

k=0

i=0

x=int(input())

while x!=0:

if x%3==0 and x%2>0:

 k+=1

x=int(input())

i+=1

print(i)

print(k)


Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных
0,0(0 оценок)
Ответ:
Vladchery
Vladchery
15.10.2020 12:39

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   RawSequence = ReadSeqWhile(int, lambda x: x != 0)

   Selector = lambda item: (item % 3 == 0) and (item % 2 != 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Число элементов, удовлетворяющих условию: {len( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота