В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
TheOll
TheOll
14.08.2021 18:48 •  Информатика

Напишите программу в питоне Формат ввода
Вводится число n, затем последовательность чисел, пока не будет введено отрицательное число (в последовательность не входит, служит признаком окончания ввода).

Формат вывода
Для каждого числа последовательности нужно найти остаток от деления его на n и вывести строку:

Показать ответ
Ответ:

using System;

namespace ConcoleApplication

{

   class Program

   {

       enum CardinalPoints //Стороны света

       {

           North,

           West,

           South,

           East

       }

       public static int Convert(int a)//Перевод команды(сделал для удобства)

       {

           if (a == -1)

               return 3;

           if (a == 1)

               return 1;

           return 2;

       }

       public static void Main()

       {

           var n1 = int.Parse(Console.ReadLine());

           var n2 = int.Parse(Console.ReadLine());

           n1 = Convert(n1);

           n2 = Convert(n2);

           var point = (n1 + n2) % 4;

           switch ((CardinalPoints) point)//Вывод ответа

           {

               case CardinalPoints.East:

                   Console.WriteLine("Восток");

                   break;

               case CardinalPoints.South:

                   Console.WriteLine("Юг");

                   break;

               case CardinalPoints.West:

                   Console.WriteLine("Запад");

                   break;

               case CardinalPoints.North:

                   Console.WriteLine("Север");

                   break;

           }

       }

   }

}

Объяснение:

Советую потестировать. Если что исправлю, самому просто лень было тестировать)

0,0(0 оценок)
Ответ:
vadimsheglov0
vadimsheglov0
17.04.2023 03:10
Теория:

По определению 1 Гц это одно колебание за секунду, а значит 32 кГц это 32 000 колебаний в секунду. У нас 16-ти битное кодирование, что означает, что каждое колебание описывается 16 битами информации. То есть, к примеру, чтобы закодировать 1 секунду нашего аудио нам нужно 16*32 000 = 512 000 бит.

Теперь к нашей задачке:

В килобайте 1024 байтов, в байте 8 бит. Считаем сколько бит в 700 кбайтах
700 * 1024 * 8 = 5 734 400

Считаем сколько колебаний мы можем описать этими данными: делим количество доступных нам бит на 16.
5 734 400 / 16 = 358 400.

Теперь нужно понять сколько это в секундах. Делим колебания на нашу частоту дискретизации (32 000):
358 400 / 32000 = 11,2 (секунд)

А если без долгих слов, то:
размер файла / битность / частота дискретизации = время звучания
700*1024*8/16/32000=11.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота