В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Локи30
Локи30
14.10.2020 12:30 •  Информатика

Напишите программу в паскале , которая зная секунды, за которые десятиклассник пробежал
2000 метров, а так же его пол, выставляет отметку по этой дисциплине.

Показать ответ
Ответ:
Исбанка
Исбанка
13.10.2020 20:31

Объяснение:

var a,b,s,o:integer;

begin

 o := 0;

 writeln('введите количество секунд');

 readln(a);

 writeln('1.муж  2.жен');

 readln(b);

 s:=0;

 if b = 1 then  

 begin

   if (a <= 400) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 500) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end

 else

 begin

   if (a <= 500) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 800) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end;

 writeln('оценка: ',o)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота