В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lmaxluk099
lmaxluk099
11.02.2020 18:57 •  Информатика

Напишите программу в паскале, которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. пример: введите три чила: 5 5 5 все числа одинаковые.

Показать ответ
Ответ:
kseniy32
kseniy32
03.07.2020 06:25
Если в три переменные:
var a,b,c:integer;
begin
writeln ('Введите 3 числа');
read (a,b,c);
if (a=b)or (a=c) or (b=c) then
begin
if (a>1) and (b>1) and (c>1)and (a=b) and (a=c) and (b=c) then //Одно ненужное условие для наглядности
writeln ('Все числа одинаковые');
if ((a>1) and (b>1) and (a=b)) or ((a>1) and (c>1) and (a=c)) or ((b>1) and (c>1) and (b=c)) then writeln (2);
end
else writeln ('Нет одинаковых чисел');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота