В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dofkatop00nj7
dofkatop00nj7
30.08.2022 13:14 •  Информатика

Напишите программу( в паскале авс), которая находит нок (наименьшее общее кратное) двух чисел, введённых с клавиатуры.

Показать ответ
Ответ:
Natashhkka
Natashhkka
25.06.2020 12:55
Для решения этой задачи воспользуемся формулой:
а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота