В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ксенияkek
Ксенияkek
16.07.2022 01:02 •  Информатика

Напишите программу в PascalABC, которая запрашивает у пользователя валютный курс на сегодняшний день, затем имеющуюся у него рублевую сумму и рассчитывает, сколько долларов и евро он может купить.​

Показать ответ
Ответ:
ark2006panozs0he
ark2006panozs0he
09.01.2021 16:26

Объяснение:

✓ this.InitializeComponet - это инициализация компонентов формы (под названием MainPage).

✓ Button_Click - это событие, вызываемое после нажатия кнопки.

✓ Double.Parse(probeg/litres) - преобразование строки в тип double.

✓ rashod.Text = присваиваем значение компоненту формы TextBox (под названием rashod).

✓ dRes.ToString("##.##") выводим текстовое значение (потому что тип double преобразуется в string) в указанном формате - ##.##

✓ double dprobeg = ... и double dlitres = ... присвоено значение в указанный компонент TextBox.

0,0(0 оценок)
Ответ:
opakp9726
opakp9726
17.01.2023 23:05

#include <iostream>

#include <string>

#define SIZE 3

/*

Структура содержит 3 поля, фамилия и оценки имеют тип string, поле с годом рождения имеет тип int;

Также имеется метод, с которого происходит ввод информации.

*/

struct student {

std::string surname;

int birthYear;

std::string marks;

void InputInfo() {

 std::cout << "Фамилия студента: ";

 getline(std::cin, surname);

 std::cout << "\nГод рождения студента: ";

 std::cin >> birthYear;

 std::cin.ignore();

 std::cout << "\nОценки студента: (через пробел): ";

 getline(std::cin, marks);

}

};

/*

В основной функции мы создаем массив структур "group" размера SIZE (SIZE объявили выше)

Затем находим сумму возрастов и делим ее на размер массива структур

*/

signed main() {

setlocale(LC_ALL, "Rus");

student group[SIZE];

int _sumAge = 0;

for (int i = 0; i < SIZE; ++i) {

 group[i].InputInfo();

 _sumAge += 2022 - group[i].birthYear;

}

std::cout << "\nСредний возраст студентов в группе:" << _sumAge / SIZE;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота