Напишите программу (в pascal abc. net) , которая в последовательности натуральных чисел ( всего чисел 10) находит сумму всех честных чисел. гарантировано в после доверенности хотя бы одно чётное число. нужно использовать цикл while
// PascalABC.NET 3.0, сборка 1088 const nDay:array[1..12] of integer=(31,28,31,30,31,30,31,31,30,31,30,31); type Date=record Day,Month,Year:integer end;
function DOW(Dat:Date):integer; // день недели по дате. 0-Вс. 1-Пн, 7-Сб var a,y,m:integer; begin With Dat do begin a:=(14 - month) div 12; y:=Year-a; m:=month+12*a-2; DOW:=(7000+(day+y+y div 4-y div 100+y div 400+(31*m) div 12)) mod 7 end end;
procedure DMY2Date(d,m,y:integer; var data:Date); // Преобразует к дате заданные день, месяц и год begin data.Day:=d; data.Month:=m; data.Year:=y end;
procedure LastDays(month,year:integer; var Wd,Fr:Date); // даты последней среды (Wd) и пятницы (Fr) для месяца в году } var LastDay:Date; n:integer; begin n:=nDay[month]; if (month=2) and (year mod 4 = 0) then Inc(n); DMY2Date(n,month,year,LastDay); n:=DOW(LastDay); // номер последнего дня недели Wd.Month:=month; Wd.Year:=year; if n<3 then Wd.Day:=LastDay.Day-(n+4) else if n=3 then Wd.Day:=LastDay.Day else Wd.Day:=LastDay.Day+3-n; Fr.Month:=month; Fr.Year:=year; if n<5 then Fr.Day:=LastDay.Day-(n+2) else if n=3 then Fr.Day:=LastDay.Day else Fr.Day:=LastDay.Day-1 end;
var Wd,Fr:Date; ff,mf:Text; m:integer; begin Assign(ff,'father.txt'); Rewrite(ff); Assign(mf,'mother.txt'); Rewrite(mf); // Сентябрь-декабрь 2015 года for m:=9 to 12 do begin LastDays(m,2015,Wd,Fr); if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2015 - 1 класс') else Writeln(ff,Wd.Day,'.',m,'.2015 - 1 класс'); if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2015 - 5 класс') else Writeln(ff,Fr.Day,'.',m,'.2015 - 5 класс') end; // Январь - май 2016 года for m:=1 to 5 do begin LastDays(m,2016,Wd,Fr); if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2016 - 1 класс') else Writeln(ff,Wd.Day,'.',m,'.2016 - 1 класс'); if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2016 - 5 класс') else Writeln(ff,Fr.Day,'.',m,'.2016 - 5 класс') end; Close(ff); Close(mf) end.
Содержимое выходных файлов: father.txt 30.9.2015 - 1 класс 28.10.2015 - 1 класс 30.10.2015 - 5 класс 30.12.2015 - 1 класс 24.2.2016 - 1 класс 26.2.2016 - 5 класс 30.3.2016 - 1 класс
mother.txt 25.9.2015 - 5 класс 25.11.2015 - 1 класс 27.11.2015 - 5 класс 25.12.2015 - 5 класс 27.1.2016 - 1 класс 29.1.2016 - 5 класс 25.3.2016 - 5 класс 27.4.2016 - 1 класс 29.4.2016 - 5 класс 25.5.2016 - 1 класс 27.5.2016 - 5 класс
1 задание) ответ: 1323141; Двигаемся в обратном порядке 2324142 (идём с конца) ей противоположные 1323141 2 задание) ответ: 2949; мы должны получить 11 и 13 причем минимально . можем только так 9+2 и 9+4 . значит 2949 3 задание) ответ: 3; чтобы добраться до 21 нам нужно выполнить 1 команду 6 раз и 3 раза вторую , нас спрашивают про вторую пишем ответ 3 4 задание) ответ: 1; нам нужно число которое делится на 5 то есть 4 отпадает , и также нам нужно чтобы модуль разности был не более 2 и во втором и в третьем модуль разности больше 2 , остается 1. 5 задание) ответ: 1112221; Я всегда начинаю с обратного 57-56-28-14-7-6-5-4 собираем с конца 1112221
const
nDay:array[1..12] of integer=(31,28,31,30,31,30,31,31,30,31,30,31);
type
Date=record
Day,Month,Year:integer
end;
function DOW(Dat:Date):integer;
// день недели по дате. 0-Вс. 1-Пн, 7-Сб
var
a,y,m:integer;
begin
With Dat do begin
a:=(14 - month) div 12;
y:=Year-a;
m:=month+12*a-2;
DOW:=(7000+(day+y+y div 4-y div 100+y div 400+(31*m) div 12)) mod 7
end
end;
procedure DMY2Date(d,m,y:integer; var data:Date);
// Преобразует к дате заданные день, месяц и год
begin
data.Day:=d; data.Month:=m; data.Year:=y
end;
procedure LastDays(month,year:integer; var Wd,Fr:Date);
// даты последней среды (Wd) и пятницы (Fr) для месяца в году }
var
LastDay:Date;
n:integer;
begin
n:=nDay[month];
if (month=2) and (year mod 4 = 0) then Inc(n);
DMY2Date(n,month,year,LastDay);
n:=DOW(LastDay); // номер последнего дня недели
Wd.Month:=month; Wd.Year:=year;
if n<3 then Wd.Day:=LastDay.Day-(n+4)
else
if n=3 then Wd.Day:=LastDay.Day
else Wd.Day:=LastDay.Day+3-n;
Fr.Month:=month; Fr.Year:=year;
if n<5 then Fr.Day:=LastDay.Day-(n+2)
else
if n=3 then Fr.Day:=LastDay.Day
else Fr.Day:=LastDay.Day-1
end;
var
Wd,Fr:Date;
ff,mf:Text;
m:integer;
begin
Assign(ff,'father.txt'); Rewrite(ff);
Assign(mf,'mother.txt'); Rewrite(mf);
// Сентябрь-декабрь 2015 года
for m:=9 to 12 do begin
LastDays(m,2015,Wd,Fr);
if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2015 - 1 класс')
else Writeln(ff,Wd.Day,'.',m,'.2015 - 1 класс');
if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2015 - 5 класс')
else Writeln(ff,Fr.Day,'.',m,'.2015 - 5 класс')
end;
// Январь - май 2016 года
for m:=1 to 5 do begin
LastDays(m,2016,Wd,Fr);
if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2016 - 1 класс')
else Writeln(ff,Wd.Day,'.',m,'.2016 - 1 класс');
if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2016 - 5 класс')
else Writeln(ff,Fr.Day,'.',m,'.2016 - 5 класс')
end;
Close(ff); Close(mf)
end.
Содержимое выходных файлов:
father.txt
30.9.2015 - 1 класс
28.10.2015 - 1 класс
30.10.2015 - 5 класс
30.12.2015 - 1 класс
24.2.2016 - 1 класс
26.2.2016 - 5 класс
30.3.2016 - 1 класс
mother.txt
25.9.2015 - 5 класс
25.11.2015 - 1 класс
27.11.2015 - 5 класс
25.12.2015 - 5 класс
27.1.2016 - 1 класс
29.1.2016 - 5 класс
25.3.2016 - 5 класс
27.4.2016 - 1 класс
29.4.2016 - 5 класс
25.5.2016 - 1 класс
27.5.2016 - 5 класс
Двигаемся в обратном порядке 2324142 (идём с конца) ей противоположные 1323141
2 задание) ответ: 2949;
мы должны получить 11 и 13 причем минимально . можем только так 9+2 и 9+4 . значит 2949
3 задание) ответ: 3;
чтобы добраться до 21 нам нужно выполнить 1 команду 6 раз и 3 раза вторую , нас спрашивают про вторую пишем ответ 3
4 задание) ответ: 1;
нам нужно число которое делится на 5 то есть 4 отпадает , и также нам нужно чтобы модуль разности был не более 2 и во втором и в третьем модуль разности больше 2 , остается 1.
5 задание) ответ: 1112221;
Я всегда начинаю с обратного
57-56-28-14-7-6-5-4 собираем с конца 1112221