В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
donik223
donik223
25.11.2021 18:08 •  Информатика

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального ( наибольшего) из введенных чисел. используйте оператор repeat.

Показать ответ
Ответ:
dasharisk2104
dasharisk2104
02.07.2020 14:56
Var
  Max, N: Integer;
  I: Integer;
begin
  I:=0;

  Repeat
    ReadLn(N);
    
    if I = 0 then
      Max:=N
    else if N > Max then
      Max:=N;

    Inc(N);
  Until(N = 0); 

  WriteLn('Max = ', Max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота