В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zakharskaoye07y
zakharskaoye07y
05.02.2020 21:15 •  Информатика

Напишите программу в которой осуществляется ввод целых чисел и подсчет суммы и среднего арифметического введенных положительных чисел используя оператор repeat

Показать ответ
Ответ:
Spudi14
Spudi14
17.07.2020 09:22
Pascal:
var
   i,sum:integer;
   sr:real;
   a:array[1..10] of integer;
begin
   writeln('Введите 10 чисел');
   for i:=1 to 10 do
       read(a[i]);
repeat
     if a[i]>0 then
       begin
          sum:=sum+a[i];
          p:=p+1;
       end;
until i:=10;
sr:=sum/p;

writeln('Сумма = ',sum,'Среднее арифмитический = ',sr);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота