В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ayserg1980ozvpli
ayserg1980ozvpli
21.04.2021 12:39 •  Информатика

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat

Показать ответ
Ответ:
медвва
медвва
13.10.2020 12:04

var a,s: integer;

begin

s:=1;

repeat

write('Введите число: ');

readln(a);

if (a>0) then s:=s*a;

until a=1;

writeln('Произведение положительных чисел: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота