В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
qwrt1337
qwrt1337
17.03.2022 02:19 •  Информатика

Напишите программу, в которой необходимо организовать ввод многомерного списка (можно использовать рандомное заполнение) и выполнение действий с ним согласно своему варианту.
Для реализации программы используйте функции.
ЗАДАНИЕ:
Введите многомерный список, состоящий из целых чисел, количество элементов
определяет пользователь. Запросите у пользователя ввести номера двух строк и поменяйте
эти строки местами.
Используйте функции для ввода и вывода многомерного списка и для замены строк.
Python

Показать ответ
Ответ:
диана2458
диана2458
11.01.2022 00:05

import random

n, m = map(int, input().split())

a = list()

for i in range(n):

   u = list()

   for j in range(m):

       u.append(random.randint(1,1000))

   a.append(u)

k, l = map(int, input().split())

print("before changing: ")

for i in range(n):

   print(*a[i], sep=" ")

for i in range(m):

   t = a[k-1][i]

   a[k-1][i] = a[l-1][i]

   a[l-1][i] = t

print("after changing: ")

for i in range(n):

   print(*a[i], sep=" ")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота