В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Otlichnisa140455
Otlichnisa140455
03.03.2020 20:38 •  Информатика

Напишите программу в C++: Найти сумму и количество целых чисел больших 20, меньших 200 и кратных 3. Вывести числа, удовлетворяющие условию, их количество, найденную сумму, среднее арифметическое. Вывести числа, заканчивающиеся на 0.

Показать ответ
Ответ:
Красотка794
Красотка794
05.01.2021 20:04

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   float summa, count = 0;

   vector<int> result, zero;

   for (int i = 21; i < 200; i++)

   {

       if (i % 3 == 0)

       {

           result.push_back(i);

           count++;

           summa += i;

           if (i % 10 == 0)

           {

               zero.push_back(i);

           }

       }

   }

   cout << R"(Числа которые заканчиваютса нулем )" << endl;

   for (int i = 0; i < zero.size(); i++)

   {

       cout << zero[i] << ' ';

   }

   cout << endl;

   cout << R"(Числа которые кратные 3)" << endl;

   for (int i = 0; i < result.size(); i++)

   {

       cout << result[i] << ' ';

   }

   cout << endl;

   cout << R"(Количество таких чисел = )" << count << endl;

Дальше немного сами подумайте если я это написал и вы это не поняли. Советую учить С++. Потому что вы не будете понимать что вы делаете.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота