В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Попрлекс
Попрлекс
02.07.2020 05:34 •  Информатика

Напишите программу со алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и на следующей строке номер последнего из его отрицательных элементов

Показать ответ
Ответ:
efanovakatena
efanovakatena
03.10.2020 08:50
Ну, значит, как-то так:

program arrays;
type
myArr = array of integer;
var
arr : myArr;
neg : integer;
i, n : integer;

begin
write('Введите размер массива: ');
readln(n);
if n>50 then n:=50;
setLength(arr, n);
randomize;
neg :=0;
for i:=0 to n-1 do begin
arr[i]:=random(200)-100;
if arr[i]<0 then neg:=arr[i];
write(arr[i], ' ');
end;
writeln;
writeln ('Последний отрицательный элемент массива: ', neg);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота