В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
roman81rudi
roman81rudi
19.04.2021 17:48 •  Информатика

Напишите программу с использованием символьных величин и строк символов:

Ввести адрес файла и «разобрать» его на части, разделенные знаком '/'. Каждую часть вывести в отдельной строке.
Пример:
Введите адрес файла:
C:/Фото/2013/Поход/vasya.jpg
C:
Фото
2013
Поход
vasya.jpg

Показать ответ
Ответ:
katyusha1514111
katyusha1514111
09.01.2023 10:11

Free Pascal

var

 a : array of array of integer;

 b : array of integer;

 s, i, j, n, m : integer;

begin

 writeln('Введите кол-во строк:');

 readln(m);

 writeln('Введите кол-во столбцов:');

 readln(n);

 randomize;

 setlength(a, n);

 setlength(b, m);

 for i:=0 to n-1 do

   setlength(a[i], m);

 for j:=0 to m-1 do begin

   s:=0;

   for i:=0 to n-1 do begin

     a[i,j] := random(50) - 25;

     if a[i,j] <0 then inc(s);

     write(a[i, j], '  ');

   end;

   b[j]:=s;

   writeln();

 end;

 writeln('--------------------------');

 for j:=0 to m-1 do

   writeln(j+1,' строка = ', b[j]);

end.


Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числам
0,0(0 оценок)
Ответ:
Coul2000nator
Coul2000nator
23.02.2023 02:09

##

var h := MatrRandom(5, 5, -7, 7);

h.Println(4);

Print('Произведение положительных элементов первой строки массива равно',

  h.Row(0).Where(t -> t > 0).Product)

------------------------

##

var h := MatrRandom(5, 5, -7, 7);

h.Println(4);

h.Transform((v, i, j) -> j.IsEven and (v < 0) ? 100 : v);

Println('Результат замены отрицательных элементов в нечетных столбцах');

h.Println(4)

---------------------

##

var h := MatrRandom(5, 5, -7, 7);

h.Println(4);

var a := h.ElementsWithIndices.Where(t -> t[2] > t[1]).Select(t -> t[0]).ToArray;

Println('Массив из элементов, стоящих над главной диагональю');

a.Print


Нужна в паскале указание:для каждой задачи создайте алгоритм и программу. заполните двумерный числов
Нужна в паскале указание:для каждой задачи создайте алгоритм и программу. заполните двумерный числов
Нужна в паскале указание:для каждой задачи создайте алгоритм и программу. заполните двумерный числов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота