В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ARISKA2006
ARISKA2006
16.02.2022 05:39 •  Информатика

Напишите программу с функцией для перевода скорости указанной в м/с в км/ч

Показать ответ
Ответ:
theartik1
theartik1
08.06.2023 21:25
PYfy9pX4YibdfKzE8dnbSXaP3D5sbZenWQXx+TzottBxmrnKP4dS39zDFCHeytaxQuaxO6+SihcUhSqF6PmmxN3GxGIIAPLiSxjqjTtSHbvo7htEBwkC9DrKA9nK9xIOxPRcjpd6DAdMG0SkqPbK1+57wXgl2KsD43bDyI91iNHZGVEFuJjW2WjoZmDZOb/rVd7R9AqyWfNwqgLu5n0s8oZKpT55zvtPlOdDo6CM93h3C9G55Qj17fBXO/NNywpSzMGUqCxZha8Dm9QprL4Amawdo2pnCyu31Kn+Zny692acWR8k+IjeIoeL9HS7GGpxomAYoUcl2QOl2meKVWiovxtHmLKNooQK1Hc8yqvu293YHqgzQp3rHNgJxPJfiQnUmlYXGvOGZLk6vEUXIiesvdftDsCS/8Ae6YiLr8HWExGez9YXrworoX46BqS86+EFy3m8zwgu1fA9z61qLUP90KYw8KxlJJDWAThAVGrADHEsoHJ35+216/jwx5ruS3xgPOL83Vy5P1bL884jUiefVsuhprgR7C75lvy2ZCUYolQ=
0,0(0 оценок)
Ответ:
spirt708ozrmv0
spirt708ozrmv0
06.02.2021 03:38
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота