В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
OctavisicStar691
OctavisicStar691
20.09.2022 03:47 •  Информатика

Напишите программу получения всех совершенных чисел из диапазона от 1 до написать через цикл while.

Показать ответ
Ответ:
kryp4
kryp4
09.10.2020 19:51

var n,i,j,s,k:integer;

begin

write('Введите число: ');

readln(n);

i:=1;

while i <= n do  

begin

j:=1;

s:=0;

while j<i

do

if i mod j = 0 then

begin

s:=s+j;

j:=j+1;

end

else

j:=j+1;

if s=i then

begin

k:=k+1;

if k=1 then write('Совершенные числа из диапазона от 1 до ',n,': ');

write(i,'  ')

end;

i:=i+1

end;

if k=0 then write('Совершенных чисел в диапазоне от 1 до ',n,' нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота