В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
bcbdbfhddhdhd
bcbdbfhddhdhd
09.01.2022 00:54 •  Информатика

Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

Показать ответ
Ответ:
Marchendro77
Marchendro77
17.06.2020 09:06

Паскаль АВС:


Program kislota;
uses crt;
const n=30;
var
  e:array[1..n] of integer;
  sum,nom,i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Элементы массива:');
  randomize;
  nom:=0;
  for i:=1 to n do
    begin
      e[i]:=random(100)-50;
      write (e[i]:5);
    end;
  sum:=e[1]+e[2];
  for i:=1 to n-1 do
    if (e[i]+1 + e[i+1])>sum then
      begin
        sum:=e[i]+1 + e[i+1];
        nom:=i;
      end;
  writeln();
  writeln('Номер первого элемента пары с максимальной суммой: ',nom);
end.

0,0(0 оценок)
Ответ:
ivankirichko2
ivankirichko2
17.06.2020 09:06

var

a:array [1..30] of integer;

i,k,s:integer;

begin

randomize;

for i:=1 to 30 do begin

a[i]:=random(9)+1;

write (a[i],' ');

end;

s:=a[1]+a[2]; 

k:=1; 

for i:=2 to 29 do

if a[i]+a[i+1]>s then begin

k:=i;

s:=a[i]+a[i+1];

end; 

writeln; 

writeln ('Number: ',k);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота