В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
123456sa
123456sa
22.02.2020 22:56 •  Информатика

Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (паскаль)

Показать ответ
Ответ:
Largo2000
Largo2000
02.10.2020 09:59
Var mas30: array [1..30] of integer;
var i, proz: integer;
begin
proz:=1;
for i:=1 to 30 do  begin mas30[i]:=-5+random (11); //Заполнение массива 
write (mas30[i], '  '); //вывод значений массива 
end; 
writeln;
for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов
writeln (proz);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота